Skip to main content
Windward

Upgrading Javelin 2014

javelin-wiki-logo.pngOverview

This document walks you through upgrading the Windward Javelin product on your own server.

Instructions

  1. Download the latest Javelin installer at http://windward.net/support/downloads.
  2. Save copies of three configuration files.
    • a. The "web.config" file where you have your Javelin site deployed (by default, this will be in "C:\wwwroot\inetpub\").
    • b. The "Javelin.Server.Service.exe.config" where you have Javelin service is installed (be default, either "C:\Program Files\Windward Studios\Windward Reports Javelin\JavelinService" or "C:\Program Files (x86)\Windward Studios\Windward Reports Javelin\JavelinService").
    • c. The "quartz.config" where you have Javelin installed (be default, either "C:\Program Files\Windward Studios\Windward Reports Javelin\JavelinService" or "C:\Program Files (x86)\Windward Studios\Windward Reports Javelin\JavelinService").
  3. Uninstall Windward Javelin.
  4. Install the newer version of Javelin that you downloaded from step 1.
  5. Copy the contents of "C:\Program Files\Windward Studios\Windward Reports Javelin\JavelinWebApplication" or "C:\Program Files (x86)\Windward Studios\Windward Reports Javelin\JavelinWebApplication" to the location of your site ("C:\wwwroot\inetpub\" by default).
  6. Copy the file from step 2a into the location of your site ("C:\wwwroot\inetpub\" by default).
  7. Copy the files from step 2b and step 2c to where you have Javelin service is installed (be default, either "C:\Program Files\Windward Studios\Windward Reports Javelin\JavelinService" or "C:\Program Files (x86)\Windward Studios\Windward Reports Javelin\JavelinService").
  8. Start the Windward Javelin Service in the service manager under Administrative tools.

 

Upgrading to Javelin 13.0+

Within the release of Javelin 13.0 came an update to use .NET Framework v4.0. This will require you to update the Internet Information Services (IIS) Manager to use .NET Framework v4.0. To do this follow the instructions below:

1. Download and install .NET Framework v4.0 (http://www.microsoft.com/en-us/downl....aspx?id=17851)

2. Open Internet Information Services (IIS) Manger (Found under Control Panel > Administrative Tools)

3. Under the "Connections" panel select the server Javelin is running on.

4. On the "Actions" panel select "Change .NET Framework Version" and change it to v4.0+.

5. Under "Connections" panel, click on "Application Pools"

6. Right-click all of the pools associated with Javelin, Click "Basic Settings..." and change the ".NET Framework version" to v4.0+.

7. Restart the server.

 

Note: If you're still having issues after upgrading to Javelin 13.0+ it may be as a result of installing .NET Framework 4.0 before setting up the server in Internet Information Services (IIS). Luckily, there is a quick fix:

1. Open Command Prompt and navigate to the .NET Framework v4.0 install directory (C:\Windows\Microsoft .NET\Framework\v4.0.30319) 

  • Note if you are on a 64-bit machine, navigate to the 64-bit install directory - not the 32-bit one.

2. Run the command "aspnet_regiis -iru".

  • Was this article helpful?